User Tag List

Página 1 de 3 123 ÚltimoÚltimo
Resultados 1 al 15 de 31

Tema: Freeletics WTF!?!?

  1. #1

    Fecha de ingreso
    Sep 2006
    Ubicación
    Malaga
    Mensajes
    5,558
    Mencionado
    35 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    846
    Agradecer Thanks Received 
    841
    Thanked in
    Agradecido 607 veces en [ARG:2 UNDEFINED] posts

    Angry Freeletics WTF!?!?

    A ver, la semana pasada hago mis entrenamientos sin problemas.

    Ayer cuando abro la aplicación para ver que me toca, me salta un mensaje de que hay una actualización... paso, que más da, intento ver que me toca pero aparece la rueda esta de progreso de manera indefinida. Porras ya se han cargado algo y necesito actualizar.

    Me voy a la AppStore, busco la aplicación y me sale el botón de abrir pero no el de actualizar... que raro. Lo miro desde el ordenador y resulta que la ultima versión necesita iOS 11, yo tengo un iPhone 5c con iOS 10.3.3.

    Les escribo el problema y les pregunto que han cambiado para que sea obligatorio usar la aplicación, llevo 5 años con ella y básicamente es la misma. Y básicamente es irte al proyecto, buscar iOS Deployment Target e ir probando con la versión mas vieja hasta que funcione.

    Y van y me cancelan la cuenta diciendo que necesito una versión más moderna, y me han devuelto parte del ultimo pago.

    Lo bueno es que me ahorran el tener que buscar cómo se cancela la cuenta, pero me parece una chapuza de proporciones bíblicas que sea obligatorio tener una versión mas moderna del SO, cuando hace 3 dias me funcionaba. Lo que no entiendo es que en el correo me pongan un código de descuento para mi próxima subscripción. XDXDXD
    No es lo mismo tener diez años de experiencia, que tener un año de experiencia diez veces.

  2. El siguiente usuario agradece a swapd0 este mensaje:

    fbustamante (03/11/2020)

  3. #2

    Fecha de ingreso
    Nov 2005
    Ubicación
    Excartagenero
    Mensajes
    19,922
    Mencionado
    218 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    3,993
    Agradecer Thanks Received 
    3,322
    Thanked in
    Agradecido 2,237 veces en [ARG:2 UNDEFINED] posts
    Entradas de blog
    1
    Eso por dejar que su gimansia depende de la tecnología!! :P

    La verdad es que sería súper útil que cuando uno instala una aplicación pueda elegir qué versión instalar.
    Luego dicen que la obsolescencia es cosa del fabricante de hardware...

    -----Actualizado-----

    Cita Iniciado por josepzin Ver mensaje
    Eso por dejar que su gimansia depende de la tecnología!! :P
    Marditos dislecsicos!

  4. El siguiente usuario agradece a josepzin este mensaje:

    fbustamante (03/11/2020)

  5. #3

    Fecha de ingreso
    Sep 2006
    Ubicación
    Malaga
    Mensajes
    5,558
    Mencionado
    35 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    846
    Agradecer Thanks Received 
    841
    Thanked in
    Agradecido 607 veces en [ARG:2 UNDEFINED] posts
    Ademas que es probar con el combo box de iOS Deployment Target para ver cual es la version mas baja donde funciona, es ridículo.

    Miremos el lado bueno, me ahorro pasta. Y puedo buscar la tabla de ejercicios y hacerlos por mi cuenta, o hacerlos de memoria, a fin de cuentas llevaba 5 años haciéndola.
    No es lo mismo tener diez años de experiencia, que tener un año de experiencia diez veces.

  6. #4

    Fecha de ingreso
    Nov 2005
    Ubicación
    Excartagenero
    Mensajes
    19,922
    Mencionado
    218 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    3,993
    Agradecer Thanks Received 
    3,322
    Thanked in
    Agradecido 2,237 veces en [ARG:2 UNDEFINED] posts
    Entradas de blog
    1
    Yo tengo instalada una que se llama Sworkit pero en la vida la usé asi que no sabría decirte si es parecida, mejor o peor.

  7. #5

    Fecha de ingreso
    Sep 2005
    Mensajes
    12,229
    Mencionado
    192 Post(s)
    Tagged
    1 Tema(s)
    Agradecer Thanks Given 
    323
    Agradecer Thanks Received 
    742
    Thanked in
    Agradecido 528 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por josepzin Ver mensaje
    La verdad es que sería súper útil que cuando uno instala una aplicación pueda elegir qué versión instalar.
    +1 O al menos que te deje la opción de revertir la actualización y quedarte en una antigua. En aplicaciones conectadas como Whatsapp o que requieran suscripción no tiene mucho sentido, quizás, pero en otras...
    Yo tengo el ES File Manager en Android y es de las mejores aplicaciones que puedes instalar... hasta la versión 3, donde le han metido tanta porquería que se ha vuelto lenta, tocha y un campo de minas de banners de publicidad. En su web se puede descargar la 1.6, pero creo que la 2.algo o las primeras 3.0 eran mejores.

    De todas formas, la obsolescencia de los cacharros no viene por el soft que instales, sino por las actualizaciones del OS. Una de las cosas que odio de Android es que no puedes impedir las actualizaciones del propio Android, y eso hace que, sin tocar nada, cada mes mi tablet sea más y más lenta. No sé cómo irá la cosa en iOS, pero creo que, aunque no se actualice solo, te "obligan" a hacerlo ¿no?
    PROYECTOS REALIZADOS: FrikiMusic, Motor Scroll Tileado v3.2, Venturer2X (GP2X/WIZ), Echo, Screen Break Time
    PROYECTOS EN MARCHA (algunos): Bennu GP2X: 95% (necesito ayuda) ¡Antes de Halloween!: 92% SpaceH2H: 8%

  8. #6

    Fecha de ingreso
    Sep 2006
    Ubicación
    Malaga
    Mensajes
    5,558
    Mencionado
    35 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    846
    Agradecer Thanks Received 
    841
    Thanked in
    Agradecido 607 veces en [ARG:2 UNDEFINED] posts
    En este caso como los ejercicios los lee desde el servidor, han cambiado algo y no se conecta, esta con la rueda de progreso indefinidamente. Y no puedo instalar la version mas moderna porque no es compatible, lo cual es ridiculo porque para mostrarte un video con una etiqueta con el tiempo y un botón para indicar que has terminado el ejercicio no se que leches necesita del iOS 11 que no tenga el 10 el 9 o el 8...
    No es lo mismo tener diez años de experiencia, que tener un año de experiencia diez veces.

  9. #7

    Fecha de ingreso
    Sep 2005
    Mensajes
    12,229
    Mencionado
    192 Post(s)
    Tagged
    1 Tema(s)
    Agradecer Thanks Given 
    323
    Agradecer Thanks Received 
    742
    Thanked in
    Agradecido 528 veces en [ARG:2 UNDEFINED] posts
    Supongo que será algo que tendrá la nueva API sobre seguridad, encriptación o algo que se asegure de que tú eres tú y no tu primo que está usando la misma cuenta o un programa de "marca blanca" para conectarse :P
    Y es raro, porque donde he trabajado siempre hemos usado una versión o dos por detrás de las librerías por compatibilidad y estabilidad, ya sea Java o Xamarin... Aunque claro, luego hay clientes que...: La versión mínima soportada por Xamarin es Android 4.4, yo hago mis pruebas en 4.1 y funcionan (hasta que dejen de hacerlo y tenga que pedir una actualización de HW ), pero es que nos ha llegado un empleado con Android 4.0.3.
    PROYECTOS REALIZADOS: FrikiMusic, Motor Scroll Tileado v3.2, Venturer2X (GP2X/WIZ), Echo, Screen Break Time
    PROYECTOS EN MARCHA (algunos): Bennu GP2X: 95% (necesito ayuda) ¡Antes de Halloween!: 92% SpaceH2H: 8%

  10. #8

    Fecha de ingreso
    Nov 2005
    Ubicación
    Excartagenero
    Mensajes
    19,922
    Mencionado
    218 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    3,993
    Agradecer Thanks Received 
    3,322
    Thanked in
    Agradecido 2,237 veces en [ARG:2 UNDEFINED] posts
    Entradas de blog
    1
    Cita Iniciado por Drumpi Ver mensaje
    No sé cómo irá la cosa en iOS, pero creo que, aunque no se actualice solo, te "obligan" a hacerlo ¿no?
    iOS no te obliga, creo... yo tengo las actualizaciones automaticas en las aplicaciones pero las del SO las tengo que hacer yo a mano y a veces tengo el aviso durante bastante tiempo hasta que me decido.

  11. #9

    Fecha de ingreso
    Sep 2005
    Mensajes
    12,229
    Mencionado
    192 Post(s)
    Tagged
    1 Tema(s)
    Agradecer Thanks Given 
    323
    Agradecer Thanks Received 
    742
    Thanked in
    Agradecido 528 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por josepzin Ver mensaje
    iOS no te obliga, creo... yo tengo las actualizaciones automaticas en las aplicaciones pero las del SO las tengo que hacer yo a mano y a veces tengo el aviso durante bastante tiempo hasta que me decido.
    Ok, mi duda era porque no sabía si al sacar una nueva versión de iOS, todas las aplicaciones se movían automáticamente a la nueva versión y te quedabas sin soporte relativamente pronto. Me daba la sensación de que al año o así se solía abandonar a su suerte la versión anterior, y que cada uno actualice o se busque la vida.
    PROYECTOS REALIZADOS: FrikiMusic, Motor Scroll Tileado v3.2, Venturer2X (GP2X/WIZ), Echo, Screen Break Time
    PROYECTOS EN MARCHA (algunos): Bennu GP2X: 95% (necesito ayuda) ¡Antes de Halloween!: 92% SpaceH2H: 8%

  12. #10

    Fecha de ingreso
    Feb 2004
    Ubicación
    Madrid
    Mensajes
    22,882
    Mencionado
    221 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    2,229
    Agradecer Thanks Received 
    1,877
    Thanked in
    Agradecido 1,170 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por Drumpi Ver mensaje
    Ok, mi duda era porque no sabía si al sacar una nueva versión de iOS, todas las aplicaciones se movían automáticamente a la nueva versión y te quedabas sin soporte relativamente pronto. Me daba la sensación de que al año o así se solía abandonar a su suerte la versión anterior, y que cada uno actualice o se busque la vida.
    Para nada. ahora mismo se soporta desde iOS 9 en adelante. Y las apps no se actualizan solas. De hecho si tienes un teléfono que sólo llegue a iOS 8 y hay versión para ese os desde la store se bajará esa versión más antigua.
    Si no la hay es porque el dev la ha quitado. Igualmente si no quieren soportar un iOS anterior es porque no les compensa sacar algo para teléfonos de hace 6-7 años porque imagino que la cuota de mercado de iOS 10 debe ser menos de un 1%.

  13. #11

    Fecha de ingreso
    Feb 2004
    Ubicación
    Madrid
    Mensajes
    22,882
    Mencionado
    221 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    2,229
    Agradecer Thanks Received 
    1,877
    Thanked in
    Agradecido 1,170 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por swapd0 Ver mensaje
    Ademas que es probar con el combo box de iOS Deployment Target para ver cual es la version mas baja donde funciona, es ridículo.

    Miremos el lado bueno, me ahorro pasta. Y puedo buscar la tabla de ejercicios y hacerlos por mi cuenta, o hacerlos de memoria, a fin de cuentas llevaba 5 años haciéndola.
    No es solo cambiar el deployment target. Es hacer build en dispositivos antiguos y probarlo (que pueden que ni tengan) y puede que cambiar la versión de swift o cualquier otra característica no soportada. Siendo programador sabes bien que esto no es a dar un botón y ya se hace solo

  14. #12

    Fecha de ingreso
    Sep 2006
    Ubicación
    Malaga
    Mensajes
    5,558
    Mencionado
    35 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    846
    Agradecer Thanks Received 
    841
    Thanked in
    Agradecido 607 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por ^MiSaTo^ Ver mensaje
    No es solo cambiar el deployment target. Es hacer build en dispositivos antiguos y probarlo (que pueden que ni tengan) y puede que cambiar la versión de swift o cualquier otra característica no soportada. Siendo programador sabes bien que esto no es a dar un botón y ya se hace solo
    Lo de darle a un botón lo digo porque en cinco años la aplicación ha cambiado muy poco, tiene una parte mas en plan "pagina web" donde puedes acceder a workouts, enlaces para dietas y algo mas que no me acuerdo, pero la parte de ejercicios es igual. Así que no entiendo que mierdas han cambiado para que ya no funcione en dispositivos antiguos.

    Me da que han cambiado ordenadores, han instalado versiones nuevas del Xcode y le han dado a actualizar el proyecto y ya esta. Que ahora la version minima es iOS 11... pues vale. Me pregunto cuantos usuarios han perdido por esta actualización.

    Por cierto han hecho lo mismo en Android, la nueva version no sale en un teléfono con android que uso de despertador básicamente XD.

    Editado: lo de darle al botón lo he dicho porque hace un par de meses hice una aplicación simple en iOS (un mapa, y un poco de core data para guardar posiciones y unos datos mas) y en mi caso si que fue cambiar el target y ya funcionaba en el iPhone5c, aunque tuve que corregir algunos elementos del interface porque no estaban bien alineados (en el editor tenia un iPhone XS como plantilla).
    Última edición por swapd0; 03/11/2020 a las 22:23
    No es lo mismo tener diez años de experiencia, que tener un año de experiencia diez veces.

  15. #13

    Fecha de ingreso
    Sep 2005
    Mensajes
    12,229
    Mencionado
    192 Post(s)
    Tagged
    1 Tema(s)
    Agradecer Thanks Given 
    323
    Agradecer Thanks Received 
    742
    Thanked in
    Agradecido 528 veces en [ARG:2 UNDEFINED] posts
    Bueno, dada la naturaleza de iOS, me extraña que no se disponga de dispositivos de testeo, porque no llegan en variedad de modelos ni al 1% en comparación con Android, que parece la ley del salvaje oeste Pero bueno, lo dice uno que desarrolla con una tablet que ni está soportada por las librerías que usa, así que...

    A ver, entiendo que una aplicación haya que probarla en distintos dispositivos, porque el SO es diferente, la pantalla es diferente, el HW es diferente... el programa es el mismo, y el compilador hace lo que está en su mano para que se pueda ejecutar...
    Pero entiendo el problema de swapd0: da mucha rabia que tu programa de uso diario deje de funcionar de la noche a la mañana. No que un programa sea incompatible desde que se crea, sino que se ha estado desarrollando para la versión x (que se ha probado, con HW real, con miles de personas, desarrollado con los mismos equipos, una y otra vez), y de pronto den el salto a la versión y y te dejen tirado "porque ya no está soportado" o "no se puede testear en ese terminal". Yo le hago eso a un cliente y me veo con la soga al cuello, pero claro, mi programa lo van a usar como máximo 100 personas; cuando tienes miles o cientos de miles no es lo mismo... pero es que a veces parece que a las desarrolladoras les da igual.
    PROYECTOS REALIZADOS: FrikiMusic, Motor Scroll Tileado v3.2, Venturer2X (GP2X/WIZ), Echo, Screen Break Time
    PROYECTOS EN MARCHA (algunos): Bennu GP2X: 95% (necesito ayuda) ¡Antes de Halloween!: 92% SpaceH2H: 8%

  16. #14

    Fecha de ingreso
    Dec 2005
    Ubicación
    alcoy, alicante
    Mensajes
    4,194
    Mencionado
    65 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    1,448
    Agradecer Thanks Received 
    697
    Thanked in
    Agradecido 394 veces en [ARG:2 UNDEFINED] posts
    Entradas de blog
    2
    @swapd0 menos mal que te han cancelado la cuenta de Freeletics, por poco pierdes el carnet del foro que aquí gordi virgen lo que más...

    saludos

  17. El siguiente usuario agradece a wolf_noir este mensaje:

    swapd0 (05/11/2020)

  18. #15

    Fecha de ingreso
    Sep 2006
    Ubicación
    Malaga
    Mensajes
    5,558
    Mencionado
    35 Post(s)
    Tagged
    0 Tema(s)
    Agradecer Thanks Given 
    846
    Agradecer Thanks Received 
    841
    Thanked in
    Agradecido 607 veces en [ARG:2 UNDEFINED] posts
    Cita Iniciado por Drumpi Ver mensaje
    Bueno, dada la naturaleza de iOS, me extraña que no se disponga de dispositivos de testeo, porque no llegan en variedad de modelos ni al 1% en comparación con Android, que parece la ley del salvaje oeste Pero bueno, lo dice uno que desarrolla con una tablet que ni está soportada por las librerías que usa, así que...

    A ver, entiendo que una aplicación haya que probarla en distintos dispositivos, porque el SO es diferente, la pantalla es diferente, el HW es diferente... el programa es el mismo, y el compilador hace lo que está en su mano para que se pueda ejecutar...
    Pero entiendo el problema de swapd0: da mucha rabia que tu programa de uso diario deje de funcionar de la noche a la mañana. No que un programa sea incompatible desde que se crea, sino que se ha estado desarrollando para la versión x (que se ha probado, con HW real, con miles de personas, desarrollado con los mismos equipos, una y otra vez), y de pronto den el salto a la versión y y te dejen tirado "porque ya no está soportado" o "no se puede testear en ese terminal". Yo le hago eso a un cliente y me veo con la soga al cuello, pero claro, mi programa lo van a usar como máximo 100 personas; cuando tienes miles o cientos de miles no es lo mismo... pero es que a veces parece que a las desarrolladoras les da igual.
    Ademas, si fuera un juego AAA que necesitas exprimir la GPU y la CPU al máximo, pues se entiende, pero para mostrar un video con un texto encima indicando el tiempo, una barra de progreso un poco custom y un botón para terminar el ejercicio... pues no creo que necesites lo ultimo de lo ultimo.

    Otra cosa, siempre que meten ejercicios nuevos, necesitas bajarte una actualización, supongo que será porque estarán hardcoded, en vez de leer una lista del servidor con los workouts/ejecicios... y mostrártela... no se, supongo que es una "consecuencia" (desarrolladores novatos) de la forma en que esta hecho.
    No es lo mismo tener diez años de experiencia, que tener un año de experiencia diez veces.

Página 1 de 3 123 ÚltimoÚltimo

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •